ESP fault, parking brake malfunction?


I’m getting this fault again. After that the car won’t start because the immobilizer cuts the fuel off.

In the past I just lock it and wait a few minutes for the computer to reset, but this time it’s being stubborn. sometimes I found that putting it in gear and setting the parking brake also helps the immobilizer reset.

The rest of the car is working just fine…

Any ideas?

This may not help you much but the ABS break module failed on my last A6 at 122k miles. I don’t remember what codes it was throwing or the exact warning lights on the dash but if I remember correctly, the brakes still worked but the ABS did not. That didn’t bother me as much as the never-ending warning lights and beeps that showed up on the dash so I finally paid to have a mechanic fix it. If I’m reading receipts correctly, it cost over $1,000 to have the ABS module replaced.

Here is the thing. I dont think those things actually think those things have a direct effect on the car starting or not starting due to the immobilizer.

Does your key fob work. As in the electronics of it. Seems like there is a signal issue that is not reconizing the cars system. This could be two things off hand. One of them would be the key and the other would be a missed communication between the ecu and the dash. If your dash was having issues that would also be an issue with the ABS showing up.

I know. it was just a ritual that seemed to work :wink:

I changed the batteries in the keys just a few weeks ago, so I don’t think that is the problem. The keys seem to communicate with the keyless entry to unlock the doors and the start button. I’ve also tried it with the key in the ignition the old fashioned way.

I just don’t know enough about the system to debug it. But “lock-wait are few minutes-unlock-go” seemed to work in the past.

It was starting to occur almost every day before I had the engine pulled last Nov. We did find a mess of burned/dried out insulation in the wiring harness under the oil filter that connects to the Bank 2 coil packs. My mechanic cut and re-soldered all the connections added additional heat insulation - plus I installed the intake spacers which seemed to keep the engine bay a little cooler. After that, life was good with no codes, no burning oil, and no ignition problems… until just recently.

This past Tuesday the same thing happened when my wife drove to work and parked outside (temp in the upper-30s) for a few hours. I came by, locked it according to the ritual above, went inside to the ATM to get some cash, and it started just fine when I returned. Then today, we stopped for 30 mins at the vet, and then when we got back to the car… nothing.

The only other thing I noticed was that the lights don’t flash when I locked the car anymore. The lights do flash when I unlock it. My mechanic thinks this may have something to do with the front passenger door lock that I replaced with a Euro salvage model. Maybe the computer is NOT getting a correct signal from this door lock - hence the immobilizer?

I’ve left the car at the vets this weekend and am at wits end. Worse, I tried to start it enough times that the battery is now weak.


…any more ideas?

I dont think its the door lock. That might be part of the no blinking lights but you would get a light on the dash for the door being open if that was the case. And I dont think the car would not start f you had the door open.

The next thing that make really good sense to me. Would be the alarm. IF the unlocking and locking helped and you dont get the blinking lights this seems to tie in. The immobilizer will block the start if the car thinks the alarm is triggered. It would make sense that your alarm is causeing these issues as it all ties in. Is there a vag com block for the alarm for the car.

Problem solved(?)

After towing the car to the garage and connecting a battery-booster we were able to go at it with the VAGCOM. My mechanic said we were getting a bad/no connection fault to the ECU so we tracked down the 12V power relays in the fuse box under the driver-side window wipers and re-seated them. Lo and behold, the car started! He opened up both relays and they seemed to be fine, but he grabbed a couple other relays from a salvage car and inserted them anyways. Car still starts fine.

Just re-seating the power relay seemed to do the trick this time. But my mechanic still thinks there might be a bad solder connection in ECU 1 that may cause the problem to surface in cold weather. He said there is no way to know for sure until it happens in the cold again, but if it did he would suggest that we open up the ECU and inspect.

I’m going to keep my fingers crossed and hope this was the definitive fix. The ESP and parking brake faults didn’t go away until we were able to put more charge back in the battery, so it makes sense that they could both be caused by a faulty power connection to the ECU. But I do know that this was happening last fall when it wasn’t that cold…

It is great that you found that out. Electronic bug out. It sucks when electronic stuff pops up it can be a nightmare. The ESP fault makes sense as that is related to communications between the two.

I dont think this solved the immobilizer issue. I think that bug might still be there some where but from the sound of it you have a few issues with electronics and wires.

Yeah. electrical problems stink. The blower motor for the heater isn’t work after we swapped out the relays - I’m guessing it’s a blown fuse. Does anyone know where it is located? I can’t find a diagram online.

You can check in your owners manual of the locaton of the fuse. But just so you know. If the S6 owners manual is like the S8 it wont even be close to the acutal fuse layout.

It wasn’t the fuse. it was a connector that was accidentally dislodged when we were changing the power relays. it took a few mins to figure out, but after checking all the fuses there was no other place to look.

Good fine those kind of things can be such a pain.

Hey man,

Do you recall which relay it was the culprit? I’m fighting the same thing after re-seating the relays.

On a side note, it looks like reseating the relays fixed my esp fault :man_shrugging: